ViewGetFilterOverrides Method |
Gets graphic overrides that a filter applies to the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic OverrideGraphicSettings GetFilterOverrides(
ElementId filterElementId
)
Public Function GetFilterOverrides (
filterElementId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ GetFilterOverrides(
ElementId^ filterElementId
)
member GetFilterOverrides :
filterElementId : ElementId -> OverrideGraphicSettings
Parameters
- filterElementId ElementId
-
ElementId of the filter.
Return Value
OverrideGraphicSettings
Object representing all graphic overrides of the filter in the view.
ExceptionsException | Condition |
---|
ArgumentException |
ElementId is not associated with a FilterElement.
-or-
Filter is not applied to the view.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
See Also