BRepBuilderAddEdge Method |
Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track
pairs of co-edges that share an edge.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BRepBuilderGeometryId AddEdge(
BRepBuilderEdgeGeometry edgeGeom
)
Public Function AddEdge (
edgeGeom As BRepBuilderEdgeGeometry
) As BRepBuilderGeometryId
public:
BRepBuilderGeometryId^ AddEdge(
BRepBuilderEdgeGeometry^ edgeGeom
)
member AddEdge :
edgeGeom : BRepBuilderEdgeGeometry -> BRepBuilderGeometryId
Parameters
- edgeGeom BRepBuilderEdgeGeometry
-
Information specifying the edge's geometry.
Return Value
BRepBuilderGeometryId
Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().
ExceptionsException | Condition |
---|
ArgumentException |
The input edge geometry was invalid.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error.
Consult the State property of the BRepBuilder object for more details.
|
See Also