ViewSectionIsParentViewValidForCallout Method |
This validator checks that the parent view is appropriate for callout views.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsParentViewValidForCallout(
Document document,
ElementId parentViewId
)
Public Shared Function IsParentViewValidForCallout (
document As Document,
parentViewId As ElementId
) As Boolean
public:
static bool IsParentViewValidForCallout(
Document^ document,
ElementId^ parentViewId
)
static member IsParentViewValidForCallout :
document : Document *
parentViewId : ElementId -> bool
Parameters
- document Document
-
The document which contains the ViewFamilyType and parent view.
- parentViewId ElementId
-
The view in which the new callout will appear.
Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation,
and Detail views.
Return Value
Boolean
True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.
Exceptions
See Also