FreeFormElementSetFaceOffset Method |
Offsets a planar face of the free form element a certain distance in the normal direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFaceOffset(
Face face,
double offset
)
Public Sub SetFaceOffset (
face As Face,
offset As Double
)
public:
void SetFaceOffset(
Face^ face,
double offset
)
member SetFaceOffset :
face : Face *
offset : float -> unit
Parameters
- face Face
-
The face to offset.
- offset Double
-
The magnitude of the offset. A positive value offsets out of the input solid. A negative value offsets into the solid shape.
ExceptionsException | Condition |
---|
ArgumentException |
face does not belong to the solid.
-or-
The face to be offset should be planar and satisfy constraints of its parent element.
|
ArgumentNullException |
A non-optional argument was null
|
See Also