VertexPositionNormalColored Constructor |
Constructs the vertex from a point, a normal vector, and a color.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VertexPositionNormalColored(
XYZ position,
XYZ normal,
ColorWithTransparency color
)
Public Sub New (
position As XYZ,
normal As XYZ,
color As ColorWithTransparency
)
public:
VertexPositionNormalColored(
XYZ^ position,
XYZ^ normal,
ColorWithTransparency^ color
)
new :
position : XYZ *
normal : XYZ *
color : ColorWithTransparency -> VertexPositionNormalColored
Parameters
- position XYZ
-
The vertex's position.
- normal XYZ
-
The vertex's normal vector.
- color ColorWithTransparency
-
The vertex's color.
Exceptions
See Also