DimensionEqualityLabelFormatting Constructor |
Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DimensionEqualityLabelFormatting(
int leadingSpaces,
string prefix,
LabelType labelType,
string suffix,
FormatOptions formatOptions
)
Public Sub New (
leadingSpaces As Integer,
prefix As String,
labelType As LabelType,
suffix As String,
formatOptions As FormatOptions
)
public:
DimensionEqualityLabelFormatting(
int leadingSpaces,
String^ prefix,
LabelType labelType,
String^ suffix,
FormatOptions^ formatOptions
)
new :
leadingSpaces : int *
prefix : string *
labelType : LabelType *
suffix : string *
formatOptions : FormatOptions -> DimensionEqualityLabelFormatting
Parameters
- leadingSpaces Int32
-
The number of spaces to include before the parameter value.
- prefix String
-
The prefix to include before the parameter value.
- labelType LabelType
-
The parameter value to be shown.
- suffix String
-
The suffix to include after the parameter value.
- formatOptions FormatOptions
-
The format options to use for the parameter value.
Exceptions
See Also