StartingViewSettingsIsAcceptableStartingView Method |
Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsAcceptableStartingView(
ElementId viewId
)
Public Function IsAcceptableStartingView (
viewId As ElementId
) As Boolean
public:
bool IsAcceptableStartingView(
ElementId^ viewId
)
member IsAcceptableStartingView :
viewId : ElementId -> bool
Parameters
- viewId ElementId
-
The Id of the element to check.
Return Value
Boolean
True if the view is acceptable, False if it is not.
Exceptions
Remarks
Model views (such as plans, ceiling plans, sections, elevations, and 3d views) are acceptable.
In addition, drafting views, sheets, legends, schedules, and graphical column schedules are generally acceptable.
Special views such as the project browser, system navigator, reports, revision schedules, internal schedules,
sheets that are not actually in use, and views that belong to a family are not acceptable.
See Also