AssemblyViewUtilsCreateMaterialTakeoff(Document, ElementId) Method |
Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ViewSchedule CreateMaterialTakeoff(
Document document,
ElementId assemblyInstanceId
)
Public Shared Function CreateMaterialTakeoff (
document As Document,
assemblyInstanceId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateMaterialTakeoff(
Document^ document,
ElementId^ assemblyInstanceId
)
static member CreateMaterialTakeoff :
document : Document *
assemblyInstanceId : ElementId -> ViewSchedule
Parameters
- document Document
-
The document to which the view will be added.
- assemblyInstanceId ElementId
-
Id of the assembly instance that owns the new view.
Return Value
ViewSchedule
A new material takeoff multicategory schedule assembly view.
Exceptions
Remarks
The material takeoff schedule will be preloaded with fields "Material: Name" and "Material: Volume".
The document must be regenerated before using the schedule.
See Also