RebarSpliceTypeUtilsGetStaggerLengthMultiplier Method |
Gets the stagger multiplier value.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static double GetStaggerLengthMultiplier(
Document document,
ElementId rebarSpliceTypeId
)
Public Shared Function GetStaggerLengthMultiplier (
document As Document,
rebarSpliceTypeId As ElementId
) As Double
public:
static double GetStaggerLengthMultiplier(
Document^ document,
ElementId^ rebarSpliceTypeId
)
static member GetStaggerLengthMultiplier :
document : Document *
rebarSpliceTypeId : ElementId -> float
Parameters
- document Document
-
The document.
- rebarSpliceTypeId ElementId
-
The Rebar Splice Type id.
Return Value
Double
Returns the stagger length multiplier value.
ExceptionsException | Condition |
---|
ArgumentException |
The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
|
ArgumentNullException |
A non-optional argument was null
|
See Also