InternalDefinitionSetAllowVaryBetweenGroups Method |
Whether or not the parameter values can vary across group members.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> SetAllowVaryBetweenGroups(
Document document,
bool allowVaryBetweenGroups
)
Public Function SetAllowVaryBetweenGroups (
document As Document,
allowVaryBetweenGroups As Boolean
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ SetAllowVaryBetweenGroups(
Document^ document,
bool allowVaryBetweenGroups
)
member SetAllowVaryBetweenGroups :
document : Document *
allowVaryBetweenGroups : bool -> ICollection<ElementId>
Parameters
- document Document
-
The document of this parameter.
- allowVaryBetweenGroups Boolean
-
Whether this parameter should be allowed to vary between groups.
Return Value
ICollectionElementId
The ids of elements that were updated to align the values between groups.
ExceptionsException | Condition |
---|
ArgumentException |
This parameter does not support the specified value of allowVaryBetweenGroups.
-or-
document is not a project document.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
When a parameter is set to not vary between groups Revit will automatically align the parameter values
of any elements that actually varied between group instances.
See Also