AreaLoadCreate(Document, ElementId, IListCurveLoop, XYZ, AreaLoadType) Method |
Creates a new custom area load within the project.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static AreaLoad Create(
Document document,
ElementId hostElemId,
IList<CurveLoop> loops,
XYZ forceVector,
AreaLoadType symbol
)
Public Shared Function Create (
document As Document,
hostElemId As ElementId,
loops As IList(Of CurveLoop),
forceVector As XYZ,
symbol As AreaLoadType
) As AreaLoad
public:
static AreaLoad^ Create(
Document^ document,
ElementId^ hostElemId,
IList<CurveLoop^>^ loops,
XYZ^ forceVector,
AreaLoadType^ symbol
)
static member Create :
document : Document *
hostElemId : ElementId *
loops : IList<CurveLoop> *
forceVector : XYZ *
symbol : AreaLoadType -> AreaLoad
Parameters
- document Document
-
Document to which new area load will be added.
- hostElemId ElementId
-
The analytical surface host element id for the area Load.
- loops IListCurveLoop
-
The loops that define geometry of the area load.
The curve loop collection should contains a closed loops consisting of lines.
- forceVector XYZ
-
The force vector applied to the 1st reference point of the area load.
- symbol AreaLoadType
-
The symbol of the AreaLoad. Set to use default type.
Return Value
AreaLoad
If successful, returns an object of the newly created AreaLoad.
is returned if the operation fails.
ExceptionsException | Condition |
---|
ArgumentException |
hostElemId is not permitted for this type of load.
-or-
One of the following requirements is not satisfied :
- curve loops loops are not planar
- curve loops loops are self-intersecting
- curve loops loops contains zero length curves
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentsInconsistentException |
Thrown if the host element id is a Curved Panel.
|
InvalidOperationException |
Thrown if type could not be set for newly created area load.
|
See Also