Offsets the given part face in the direction that points out of the solid shape with the specified amount.
Negative value will offset the face into the solid shape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFaceOffset(
Face face,
double offset
)
Public Sub SetFaceOffset (
face As Face,
offset As Double
)
public:
void SetFaceOffset(
Face^ face,
double offset
)
member SetFaceOffset :
face : Face *
offset : float -> unit
Parameters
- face Face
-
The face to offset.
- offset Double
-
The magnitude of the offset.
ExceptionsException | Condition |
---|
ArgumentException |
face does not belong to the part.
-or-
The face to be offset should be planar and satisfy constraints of its parent element
|
ArgumentNullException |
A non-optional argument was null
|
See Also