IModelExportContextOnPoint Method |
This method is called when a Point is being output.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxRenderNodeAction OnPoint(
PointNode node
)
Function OnPoint (
node As PointNode
) As RenderNodeAction
RenderNodeAction OnPoint(
PointNode^ node
)
abstract OnPoint :
node : PointNode -> RenderNodeAction
Parameters
- node PointNode
-
An output node that represents a Point.
Return Value
RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive low-level geometry
(line segments) for this point, or otherwise return RenderNodeAction.Skip.
Remarks
Note that this method is invoked only if the custom exporter
was set up to include geometric objects in the output stream.
See
IncludeGeometricObjects for mode details.
See Also