TessellatedFace Class

Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTessellatedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TessellatedFace : IDisposable

The TessellatedFace type exposes the following members.

Constructors
 NameDescription
Public methodTessellatedFace(IListXYZ, ElementId) Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Public methodTessellatedFace(IListIListXYZ, ElementId) Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMaterialId Material of the face.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TessellatedFace
Public methodGetBoundaryLoops Get loops bounding the face.
Top
See Also