RebarShapeDefinitionBySegmentsAddListeningDimensionSegmentToSegment Method |
Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddListeningDimensionSegmentToSegment(
ElementId paramId,
double constraintDirCoordX,
double constraintDirCoordY,
int iSegment0,
int iSegment1
)
Public Sub AddListeningDimensionSegmentToSegment (
paramId As ElementId,
constraintDirCoordX As Double,
constraintDirCoordY As Double,
iSegment0 As Integer,
iSegment1 As Integer
)
public:
void AddListeningDimensionSegmentToSegment(
ElementId^ paramId,
double constraintDirCoordX,
double constraintDirCoordY,
int iSegment0,
int iSegment1
)
member AddListeningDimensionSegmentToSegment :
paramId : ElementId *
constraintDirCoordX : float *
constraintDirCoordY : float *
iSegment0 : int *
iSegment1 : int -> unit
Parameters
- paramId ElementId
-
Id of a parameter to report the length of the dimension. The parameter will be read-only
on Rebar instances.
- constraintDirCoordX Double
-
The x-coordinate of a 2D vector specifying the constraint direction.
- constraintDirCoordY Double
-
The y-coordinate of a 2D vector specifying the constraint direction.
- iSegment0 Int32
-
Index of the first segment (0 to NumberOfSegments - 1).
- iSegment1 Int32
-
Index of the second segment (0 to NumberOfSegments - 1).
ExceptionsException | Condition |
---|
ArgumentException |
paramId is not the id of a shared parameter in the current document,
or its unit type is not UT_Reinforcement_Length or UT_Angle.
-or-
The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero.
-or-
iSegment0 is not between 0 and NumberOfSegments.
-or-
iSegment1 is not between 0 and NumberOfSegments.
-or-
Edge iSegment0 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY).
-or-
Edge iSegment1 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY).
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.
See Also