FamilyInstanceHost Property |
If the instance is contained within another element, this property returns the containing
element. An instance that is face hosted will return the element containing the face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Element Host { get; }
Public ReadOnly Property Host As Element
Get
public:
property Element^ Host {
Element^ get ();
}
member Host : Element with get
Property Value
Element
RemarksAn example of an instance that is contained is a window. In this case the host property
would return the wall in which the window is contained. Another example is an instance that is hosted
to a planar or curved face in a Mass element will return the Mass element.
See Also