RebarSpliceTypeUtilsGetAllRebarSpliceTypes Method |
Gets all the Rebar Splice Types elements from the document.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetAllRebarSpliceTypes(
Document document
)
Public Shared Function GetAllRebarSpliceTypes (
document As Document
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetAllRebarSpliceTypes(
Document^ document
)
static member GetAllRebarSpliceTypes :
document : Document -> IList<ElementId>
Parameters
- document Document
-
The document.
Return Value
IListElementId
Returns all the Rebar Splice Types elements from the document.
Exceptions
Remarks
Internally this function is returning all element ids from a FilteredElementCollector of category BuiltInCategory.OST_RebarSpliceType.
See Also