VertexFormatBits Enumeration |
Vertex format (i.e., the type of data associated with a vertex) represented as a number.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum VertexFormatBits
Public Enumeration VertexFormatBits
public enum class VertexFormatBits
MembersMember name | Value | Description |
---|
Position | 1 |
Vertex format consisting of a position.
|
PositionNormal | 3 |
Vertex format consisting of a position and a normal vector.
|
PositionColored | 5 |
Vertex format consisting of a position and a color.
|
PositionNormalColored | 7 |
Vertex format consisting of a position, a normal vector, and a color.
|
Remarks
VertexFormatBits can be used to specify the vertex format in the creation of the following objects:
- EffectInstance
- VertexFormat
VertexFormatBits is not to be confused with VertexFormat. The latter type of object is associated with low-level graphics
functionality and may become invalid. VertexFormat is needed to submit a set of vertex and index buffers for rendering (see
DrawContext).
See Also