JoinGeometryUtilsAreElementsJoined Method |
Determines whether two elements are joined.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool AreElementsJoined(
Document document,
Element firstElement,
Element secondElement
)
Public Shared Function AreElementsJoined (
document As Document,
firstElement As Element,
secondElement As Element
) As Boolean
public:
static bool AreElementsJoined(
Document^ document,
Element^ firstElement,
Element^ secondElement
)
static member AreElementsJoined :
document : Document *
firstElement : Element *
secondElement : Element -> bool
Parameters
- document Document
-
The document containing the two elements.
- firstElement Element
-
The first element.
- secondElement Element
-
The second element.
Return Value
Boolean
True if the two elements are joined.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a project document.
-or-
The element firstElement was not found in the given document.
-or-
The element secondElement was not found in the given document.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
This functionality is not available for family documents.
See Also