MEPAnalyticalConnectionCreate Method |
Creates a new analytical connection between two open connectors.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MEPAnalyticalConnection Create(
Document doc,
ElementId typeId,
Connector startConnector,
Connector endConnector
)
Public Shared Function Create (
doc As Document,
typeId As ElementId,
startConnector As Connector,
endConnector As Connector
) As MEPAnalyticalConnection
public:
static MEPAnalyticalConnection^ Create(
Document^ doc,
ElementId^ typeId,
Connector^ startConnector,
Connector^ endConnector
)
static member Create :
doc : Document *
typeId : ElementId *
startConnector : Connector *
endConnector : Connector -> MEPAnalyticalConnection
Parameters
- doc Document
-
The document where the new element is created.
- typeId ElementId
-
The type of new analytical connection.
- startConnector Connector
-
The open connector on the equipment side, whose level is inherited by the analytical connection.
- endConnector Connector
-
The open connector on the network.
Return Value
MEPAnalyticalConnection
The newly created analytical connection element.
Exceptions
See Also