ExportLayerTableGetAvaliableLayerModifierTypes Method |
Gets all the avaliable layer modifier types for the layer key.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ModifierType> GetAvaliableLayerModifierTypes(
Document document,
ExportLayerKey exportLayerKey
)
Public Shared Function GetAvaliableLayerModifierTypes (
document As Document,
exportLayerKey As ExportLayerKey
) As IList(Of ModifierType)
public:
static IList<ModifierType>^ GetAvaliableLayerModifierTypes(
Document^ document,
ExportLayerKey^ exportLayerKey
)
static member GetAvaliableLayerModifierTypes :
document : Document *
exportLayerKey : ExportLayerKey -> IList<ModifierType>
Parameters
- document Document
-
A Revit document to retrieve avaliable layer modifier types from.
- exportLayerKey ExportLayerKey
-
The export layer key to specify wich category and subCategory will be used to get the layer modifier types.
Return Value
IListModifierType
The layer modifier types.
Exceptions
See Also