ModifierType Enumeration

An enumerated type listing options to appear in the exported layer name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ModifierType
Members
Member nameValueDescription
Category0 Signals that the name of the category will appear in the layer name.
Custom11 Signals that the first custom string will appear in the layer name.
Custom22 Signals that the second custom string will appear in the layer name.
Custom33 Signals that the third custom string will appear in the layer name.
FireRating4 Signals that the value of fire rating will appear in the layer name.
Function5 Signals that the value of function will appear in the layer name.
Level6 Signals that the name of the level will appear in the layer name.
PhaseCreated7 Signals that the name of the created phase will appear in the layer name.
PhaseDemolished8 Signals that the name of the demolition phase will appear in the layer name.
PhaseStatus9 Signals that the value of of phase status will appear in the layer name.
UnknownType-1 An unknown (default) type of modifier, not acceptable for assignment.
StructuralMaterialType10 Signals that the value of structural material type will appear in the layer name.
StructuralUsage11 Signals that the value of structural usage will appear in the layer name.
SystemName12 Signals that the system name will appear in the layer name.
SystemType13 Signals that the system type will appear in the layer name.
Underlay14 Signals that the name of the underlay will appear in the layer name.
ViewType15 Signals that the view type will appear in the layer name.
Workset16 Signals that the name of the workset will appear in the layer name.
AnalyzesAs17 Signals that the value of the AnalyzesAs parameter will appear in the layer name.
SystemClassification18 Signals that the system classification will appear in the layer name.
DomainType19 Signals that the domain type will appear in the layer name.
FabricationService20 Signals that the fabrication service will appear in the layer name.
See Also