AdaptiveComponentFamilyUtilsGetPointOrientationType Method |
Gets orientation type of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static AdaptivePointOrientationType GetPointOrientationType(
Document doc,
ElementId refPointId
)
Public Shared Function GetPointOrientationType (
doc As Document,
refPointId As ElementId
) As AdaptivePointOrientationType
public:
static AdaptivePointOrientationType GetPointOrientationType(
Document^ doc,
ElementId^ refPointId
)
static member GetPointOrientationType :
doc : Document *
refPointId : ElementId -> AdaptivePointOrientationType
Parameters
- doc Document
-
The Document
- refPointId ElementId
-
The ReferencePoint id
Return Value
AdaptivePointOrientationType
Orientation type of Adaptive Placement Point.
ExceptionsException | Condition |
---|
ArgumentException |
The ElementId refPointId does not correspond to a valid ReferencePoint.
-or-
The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
-or-
The ElementId refPointId does not correspond to an Adaptive Placement Point.
|
ArgumentNullException |
A non-optional argument was null
|
See Also