FabricationHostedInfoPlaceOnHost(ElementId, Connector, Double) Method |
Places the part on the specified host.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void PlaceOnHost(
ElementId hostId,
Connector hostConnector,
double distance
)
Public Sub PlaceOnHost (
hostId As ElementId,
hostConnector As Connector,
distance As Double
)
public:
void PlaceOnHost(
ElementId^ hostId,
Connector^ hostConnector,
double distance
)
member PlaceOnHost :
hostId : ElementId *
hostConnector : Connector *
distance : float -> unit
Parameters
- hostId ElementId
-
Identifier of the host fabrication part.
- hostConnector Connector
-
The connector of the host.
- distance Double
-
The distance from the connector to place the hosted part. Units are in feet (ft).
ExceptionsException | Condition |
---|
ArgumentException |
Invalid fabrication part host. The host should be a straight fabrication part.
-or-
Invalid connector of fabrication part host.
-or-
The distance is out of range.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The document must be regenerated before the fabrication part can be used.
Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also