IFCExtrusionCalculatorOptions Constructor |
Constructs a new instance of a class used to calculate extrusions from Revit geometry.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IFCExtrusionCalculatorOptions(
ExporterIFC exporterIFC,
IFCExtrusionAxes extrusionAxes,
XYZ customAxis,
double scale
)
Public Sub New (
exporterIFC As ExporterIFC,
extrusionAxes As IFCExtrusionAxes,
customAxis As XYZ,
scale As Double
)
public:
IFCExtrusionCalculatorOptions(
ExporterIFC^ exporterIFC,
IFCExtrusionAxes extrusionAxes,
XYZ^ customAxis,
double scale
)
new :
exporterIFC : ExporterIFC *
extrusionAxes : IFCExtrusionAxes *
customAxis : XYZ *
scale : float -> IFCExtrusionCalculatorOptions
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- extrusionAxes IFCExtrusionAxes
-
The extrusion axes to try when doing the calculation.
- customAxis XYZ
-
The custom axis to try (if extrusionAxes includes an option for a custom direction).
- scale Double
-
The scaling factor for length measurements from the default Revit units to the export units.
Exceptions
See Also