ColumnAttachmentIsValidTarget(Boolean, Element) Method |
Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidTarget(
bool forSlantedColumn,
Element target
)
Public Shared Function IsValidTarget (
forSlantedColumn As Boolean,
target As Element
) As Boolean
public:
static bool IsValidTarget(
bool forSlantedColumn,
Element^ target
)
static member IsValidTarget :
forSlantedColumn : bool *
target : Element -> bool
Parameters
- forSlantedColumn Boolean
-
If true, check whether the target is valid for a slanted column;
if false, check whether the target is valid for a vertical column.
- target Element
-
A proposed target element for a column attachment.
Return Value
Boolean
Exceptions
Remarks
Valid targets are roofs, floors, ceilings, levels. Beams and braces
are valid targets, except for slanted columns.
See Also