GroupHideAttachedDetailGroups Method

Hides the element group's attached detail groups of the input group type that are compatible with the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void HideAttachedDetailGroups(
	View view,
	ElementId detailGroupTypeId
)

Parameters

view  View
The view that the attached detail groups must be compatible with.
detailGroupTypeId  ElementId
Only attached detail groups of this type will be hidden.
Exceptions
ExceptionCondition
ArgumentException The attached detail group detailGroupTypeId does not match the input view's orientation.
ArgumentNullException A non-optional argument was null
InvalidOperationException The input group is not a model group and can therefore not have attached detail groups.
See Also