FailureMessageSetFailingElement Method |
Sets the element that has caused the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FailureMessage SetFailingElement(
ElementId id
)
Public Function SetFailingElement (
id As ElementId
) As FailureMessage
public:
FailureMessage^ SetFailingElement(
ElementId^ id
)
member SetFailingElement :
id : ElementId -> FailureMessage
Parameters
- id ElementId
-
The element that has caused the failure.
Return Value
FailureMessage
The FailureMessage.
Exceptions
Remarks
In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.
See Also