RebarBendingDetailSetTagRelativeRotation Method |
Sets the embedded tag rotation angle w.r.t. the realistic bending detail element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetTagRelativeRotation(
Element bendingDetail,
double rotation
)
Public Shared Sub SetTagRelativeRotation (
bendingDetail As Element,
rotation As Double
)
public:
static void SetTagRelativeRotation(
Element^ bendingDetail,
double rotation
)
static member SetTagRelativeRotation :
bendingDetail : Element *
rotation : float -> unit
Parameters
- bendingDetail Element
-
The bending detail element.
- rotation Double
-
The new rotation angle of the embedded tag w.r.t. the bending detail element.
ExceptionsException | Condition |
---|
ArgumentException |
This option is only available for realistic bending detail elements.
-or-
The given value for rotation is not a number
-or-
The given value for rotation is not finite
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
This function is exclusive to realistic bending detail mode.
See Also