BeamSystemCreate(Document, IListCurve, Level, Int32, Boolean) Method |
Creates a new BeamSystem with specified profile curves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static BeamSystem Create(
Document document,
IList<Curve> profile,
Level level,
int curveIndexForDirection,
bool is3d
)
Public Shared Function Create (
document As Document,
profile As IList(Of Curve),
level As Level,
curveIndexForDirection As Integer,
is3d As Boolean
) As BeamSystem
public:
static BeamSystem^ Create(
Document^ document,
IList<Curve^>^ profile,
Level^ level,
int curveIndexForDirection,
bool is3d
)
static member Create :
document : Document *
profile : IList<Curve> *
level : Level *
curveIndexForDirection : int *
is3d : bool -> BeamSystem
Parameters
- document Document
-
The document in which the new BeamSystem is created.
- profile IListCurve
-
The profile of the BeamSystem.
- level Level
-
The level on which the BeamSystem is to be created.
The work-plane of the BeamSystem will be the sketch plane associated with the Level.
If there is no current sketch plane associated with the level yet, we will create a default one.
- curveIndexForDirection Int32
-
Index of the curve in the profile to be used as direction.
'0' means the direction to use the first curve in profile.
The curve from the profile to be used as direction must be a Line.
- is3d Boolean
-
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.
Return Value
BeamSystem
If successful, a new BeamSystem object will be returned.
ExceptionsException | Condition |
---|
ArgumentException |
The input profile contains at least one helical curve and is not supported for this operation.
-or-
The curve index must be valid and the curve to be used as direction must be a Line.
-or-
The input level does not have associated plan view.
-or-
The plan view associated with the input level is not valid.
-or-
Can not get valid sketch plane from the input level.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Example
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
List<Curve> profile = new List<Curve>();
profile.Add(Line.CreateBound(first, second));
profile.Add(Line.CreateBound(second, third));
profile.Add(Line.CreateBound(third, fourth));
profile.Add(Line.CreateBound(fourth, first));
BeamSystem beamSystem = BeamSystem.Create(document, profile, level, 0, false);
if (null != beamSystem)
{
Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
if (null != elevationPara)
{
elevationPara.Set(10.0);
}
}
Dim first As New XYZ(0, 0, 0)
Dim second As New XYZ(40, 0, 0)
Dim third As New XYZ(40, 25, 0)
Dim fourth As New XYZ(0, 25, 0)
Dim profile As New List(Of Curve)()
profile.Add(Line.CreateBound(first, second))
profile.Add(Line.CreateBound(second, third))
profile.Add(Line.CreateBound(third, fourth))
profile.Add(Line.CreateBound(fourth, first))
Dim beamSystem__1 As BeamSystem = BeamSystem.Create(document, profile, level, 0, False)
If beamSystem__1 IsNot Nothing Then
Dim elevationPara As Parameter = beamSystem__1.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
If elevationPara IsNot Nothing Then
elevationPara.[Set](10.0)
End If
End If
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also