FilteredElementCollectorOfCategoryId Method |
Applies an ElementCategoryFilter to the collector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilteredElementCollector OfCategoryId(
ElementId categoryId
)
Public Function OfCategoryId (
categoryId As ElementId
) As FilteredElementCollector
public:
FilteredElementCollector^ OfCategoryId(
ElementId^ categoryId
)
member OfCategoryId :
categoryId : ElementId -> FilteredElementCollector
Parameters
- categoryId ElementId
-
The category id.
Return Value
FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned
so you can chain multiple calls together in one line.
Exceptions
Remarks
Only elements of this category id will pass the collector.
If you have an active iterator to this collector it will be stopped by this call.
See Also