FamilyInstanceFilter Constructor |
Constructs a new instance of a filter to match family instances of the given family symbol.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceFilter(
Document document,
ElementId familySymbolId
)
Public Sub New (
document As Document,
familySymbolId As ElementId
)
public:
FamilyInstanceFilter(
Document^ document,
ElementId^ familySymbolId
)
new :
document : Document *
familySymbolId : ElementId -> FamilyInstanceFilter
Parameters
- document Document
-
The document. This requirement is unique to this filter and is needed to ensure the input
family symbol id is valid for the provided document. This ensures the most stability and
greatest performance for this filter.
- familySymbolId ElementId
-
The family symbol id.
Exceptions
See Also