FamilyUtilsFamilyCanConvertToFaceHostBased Method |
Indicates whether the family can be converted to face host based.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool FamilyCanConvertToFaceHostBased(
Document document,
ElementId familyId
)
Public Shared Function FamilyCanConvertToFaceHostBased (
document As Document,
familyId As ElementId
) As Boolean
public:
static bool FamilyCanConvertToFaceHostBased(
Document^ document,
ElementId^ familyId
)
static member FamilyCanConvertToFaceHostBased :
document : Document *
familyId : ElementId -> bool
Parameters
- document Document
-
The document.
- familyId ElementId
-
The element id of the family.
Return Value
Boolean
True if the family can be converted to face-based.
Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host.
Also, false is returned if the family does not belong to one of the following categories:
- OST_CommunicationDevices
- OST_DataDevices
- OST_DuctTerminal
- OST_ElectricalEquipment
- OST_ElectricalFixtures
- OST_FireAlarmDevices
- OST_LightingDevices
- OST_LightingFixtures
- OST_MechanicalControlDevices
- OST_MechanicalEquipment
- OST_NurseCallDevices
- OST_PlumbingEquipment
- OST_PlumbingFixtures
- OST_SecurityDevices
- OST_Sprinklers
- OST_TelephoneDevices
Exceptions
See Also