LayerModifier(ModifierType, String) Constructor

Constructs a new LayerModifier with modifierType and separator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LayerModifier(
	ModifierType modifierType,
	string separator
)

Parameters

modifierType  ModifierType
The modifier type.
separator  String
The separator string that will follow this modifier in the export layer name.
Exceptions
ExceptionCondition
ArgumentException The provided separator contains invalid characters (most special characters are invalid).
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also