RevisionCloudRevisionId Property |
The Revision associated with this RevisionCloud.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId RevisionId { get; set; }
Public Property RevisionId As ElementId
Get
Set
public:
property ElementId^ RevisionId {
ElementId^ get ();
void set (ElementId^ value);
}
member RevisionId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: revisionId is not a valid Revision.
-or-
When setting this property: This operation cannot be performed because revisionId is an issued Revision.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InvalidOperationException |
When setting this property: This operation cannot be performed on a RevisionCloud associated with a Revision that has been issued.
|
Remarks
This property cannot be set to a Revision that has already been issued. If this RevisionCloud is already associated
with a Revision that has been issued then this property cannot be changed.
See Also