GroupIsCompatibleAttachedDetailGroupType Method |
Checks if the orientation of the input attached detail group matches the input view's orientation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsCompatibleAttachedDetailGroupType(
View view,
ElementId detailGroupTypeId
)
Public Function IsCompatibleAttachedDetailGroupType (
view As View,
detailGroupTypeId As ElementId
) As Boolean
public:
bool IsCompatibleAttachedDetailGroupType(
View^ view,
ElementId^ detailGroupTypeId
)
member IsCompatibleAttachedDetailGroupType :
view : View *
detailGroupTypeId : ElementId -> bool
Parameters
- view View
-
The view that the input attached detail group must be compatible with.
- detailGroupTypeId ElementId
-
The attached detail group that will be checked for compatibility with the input view.
Return Value
Boolean
Returns true if the input attached detail group is compatible with the input view and false otherwise.
Exceptions
Remarks
Currently, detail groups in perpendicular elevation views (for example, North and East views)
are considered compatible. When showing these detail groups, an error (FailureMessage) based on
id can be generated if the orientation of the annotations do not match the orientation of the
target view (for example, the failure definition DimensionPerpendicularToView). To prevent
displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group
to make sure it matches the view in which you are trying to display it.
See Also