ElectricalAnalyticalNodeGetDownstreamNodeIds Method |
Gets the downstream node ids.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> GetDownstreamNodeIds()
Public Function GetDownstreamNodeIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetDownstreamNodeIds()
member GetDownstreamNodeIds : unit -> IList<ElementId>
Return Value
IListElementId
The array of downstream node ids.
Remarks
If node B supplies from node A, node B is the downstream node of node A, and node A is the upstream node of node B.
Usually one node may have many downstream nodes, but TransferSwitch can only have one downstream node.
See Also