ConceptualConstructionTypeIsValidSurfaceSubcategoryForConstruction Method |
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidSurfaceSubcategoryForConstruction(
ElementId massSurfaceSubcategoryId
)
Public Function IsValidSurfaceSubcategoryForConstruction (
massSurfaceSubcategoryId As ElementId
) As Boolean
public:
bool IsValidSurfaceSubcategoryForConstruction(
ElementId^ massSurfaceSubcategoryId
)
member IsValidSurfaceSubcategoryForConstruction :
massSurfaceSubcategoryId : ElementId -> bool
Parameters
- massSurfaceSubcategoryId ElementId
-
The ElementId of a Mass subcategory of a MassSurfaceData.
Return Value
Boolean
Returns true if appropriate for the input subcategory, false otherwise.
Exceptions
See Also