CurveElementGetAdjoinedCurveElements Method |
Returns elements that are joining with this curve element at the given end point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetAdjoinedCurveElements(
int end
)
Public Function GetAdjoinedCurveElements (
end As Integer
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAdjoinedCurveElements(
int end
)
member GetAdjoinedCurveElements :
end : int -> ISet<ElementId>
Parameters
- end Int32
-
Id of one the curve's end. Value '0' indicates start and '1' indicates the end of the curve, respectively.
Return Value
ISetElementId
Collection of Ids of Curve Elements.
ExceptionsException | Condition |
---|
ArgumentException |
The given Id does not represent any of the two end-points of a curve element.
A valid value of either '0' or '1' is expected.
|
See Also