LabelUtilsGetLabelForSpec Method |
Gets the user-visible name for a spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static string GetLabelForSpec(
ForgeTypeId specTypeId
)
Public Shared Function GetLabelForSpec (
specTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForSpec(
ForgeTypeId^ specTypeId
)
static member GetLabelForSpec :
specTypeId : ForgeTypeId -> string
Parameters
- specTypeId ForgeTypeId
-
Identifier of the spec to get the user-visible name.
Return Value
String
Exceptions
Remarks
The name is obtained in the current Revit language.
If the given identifier is a category, this method returns the name
of the Family Type spec with that category, e.g. "Family Type: Walls".
See Also