AnalyticalMemberSectionTypeId Property |
The id of the type from the structural Family assigned to the Analytical Member.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId SectionTypeId { get; set; }
Public Property SectionTypeId As ElementId
Get
Set
public:
property ElementId^ SectionTypeId {
ElementId^ get ();
void set (ElementId^ value);
}
member SectionTypeId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: sectionTypeId is the id of some element that is not a
FamilySymbol or is not of the category "Structural Framing"
(OST_StructuralFraming) or "Structural Columns" (OST_StructuralColumns)
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
The type must be of category "Structural Framing"
(OST_StructuralFraming) or "Structural Columns" (OST_StructuralColumns)
See Also