RebarBarTypeSetHookOffsetLength Method |
Identifies the hook offset length for a hook type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetHookOffsetLength(
ElementId hookId,
double newLength
)
Public Sub SetHookOffsetLength (
hookId As ElementId,
newLength As Double
)
public:
void SetHookOffsetLength(
ElementId^ hookId,
double newLength
)
member SetHookOffsetLength :
hookId : ElementId *
newLength : float -> unit
Parameters
- hookId ElementId
-
id of the hook type
- newLength Double
-
The hook offset length for a hook type
ExceptionsException | Condition |
---|
ArgumentException |
the rebar hook type id hookId is not valid
-or-
the hook specified by id hookId doesn't have valid offset length
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
AutoCalcHookLengths is ignored when this property is set
See Also