TransactionGroupStart(String) Method |
Starts the transaction group with an assigned name.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TransactionStatus Start(
string transGroupName
)
Public Function Start (
transGroupName As String
) As TransactionStatus
public:
TransactionStatus Start(
String^ transGroupName
)
member Start :
transGroupName : string -> TransactionStatus
Parameters
- transGroupName String
-
Name of the group.
The name will be used only for a group that is assimilated at the end.
Return Value
TransactionStatus
If started successfully, this method returns TransactionStatus.Started.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled.
-or-
Transaction group cannot be started during an active transaction.
-or-
The Transaction group has already been started.
|
Remarks
A transaction group can be started only when there is no transaction started currently.
It can be started inside another transaction group though. With such group nesting
it is required that inner transaction groups are finished (i.e. rolled back, committed,
or assimilated) before outer groups are.
See Also