TransformWithBoundary Class

This class contains the transform from model space to projection space for a view and the boundary in model space in which the transform is valid.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTransformWithBoundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TransformWithBoundary : IDisposable

The TransformWithBoundary type exposes the following members.

Constructors
 NameDescription
Public methodTransformWithBoundary Constructs a new copy of the input TransformWithBoundary object.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TransformWithBoundary
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundary Returns the boundary for the model space to view projection space transform.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetModelToProjectionTransform Gets the model space to view projection space transform.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

Use the model-to-projection transform returned by GetModelToProjectionTransform to transform model points to the view's projection space. The model-to-projection transform is only valid for points in 3D model space that that can be seen through the 2D boundary returned by GetBoundary, when looking in the direction of [!:View.ViewDirection].

For views that are placed on sheets, you can combine the View's model-to-projection transform and the Viewport's projection-to-sheet transform to transform model points to sheet space:

sheetXYZ = projectionToSheetTransform * modelToProjectionTransform * modelXYZ

Model space is the global 3D coordinate space in which the 3D geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

Sheet space is the coordinate space of one sheet. This is the space in which viewports and titleblocks are arranged on the sheet.

See Also