ElementTransformUtilsRotateElements Method |
Rotates a set of elements about the given axis and angle.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void RotateElements(
Document document,
ICollection<ElementId> elementsToRotate,
Line axis,
double angle
)
Public Shared Sub RotateElements (
document As Document,
elementsToRotate As ICollection(Of ElementId),
axis As Line,
angle As Double
)
public:
static void RotateElements(
Document^ document,
ICollection<ElementId^>^ elementsToRotate,
Line^ axis,
double angle
)
static member RotateElements :
document : Document *
elementsToRotate : ICollection<ElementId> *
axis : Line *
angle : float -> unit
Parameters
- document Document
-
The document that owns the elements.
- elementsToRotate ICollectionElementId
-
The set of elements to rotate.
- axis Line
-
The axis of rotation.
- angle Double
-
The angle of rotation in radians.
ExceptionsException | Condition |
---|
ArgumentException |
The given element id set is empty.
-or-
One or more elements in elementsToRotate do not exist in the document.
|
ArgumentNullException |
A non-optional argument was null
|
See Also