SchedulableField(ScheduleFieldType, ElementId) Constructor |
Creates a new SchedulableField.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SchedulableField(
ScheduleFieldType fieldType,
ElementId parameterId
)
Public Sub New (
fieldType As ScheduleFieldType,
parameterId As ElementId
)
public:
SchedulableField(
ScheduleFieldType fieldType,
ElementId^ parameterId
)
new :
fieldType : ScheduleFieldType *
parameterId : ElementId -> SchedulableField
Parameters
- fieldType ScheduleFieldType
-
The type of data displayed by the field.
- parameterId ElementId
-
The ID of the parameter displayed by the field.
ExceptionsException | Condition |
---|
ArgumentException |
fieldType is not a schedulable field type
-or-
The fieldType can't be CustomField. To create a CustomField, you should use the constructor which receives the custom field server id as a parameter.
|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
See Also