SpatialFieldManagerAddSpatialFieldPrimitive(Curve, Transform) Method |
Creates empty analysis results primitive associated with a curve and a transform.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int AddSpatialFieldPrimitive(
Curve curve,
Transform trf
)
Public Function AddSpatialFieldPrimitive (
curve As Curve,
trf As Transform
) As Integer
public:
int AddSpatialFieldPrimitive(
Curve^ curve,
Transform^ trf
)
member AddSpatialFieldPrimitive :
curve : Curve *
trf : Transform -> int
Parameters
- curve Curve
-
Curve to be associated with the primitive.
%curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference;
otherwise the other overload of the method must be used (taking "reference" as the input)
- trf Transform
-
Conformal Transform to be applied to %curve%.
Return Value
Int32
Unique index of primitive for future references
ExceptionsException | Condition |
---|
ArgumentException |
The input curve points to a helical curve and is not supported for this operation.
-or-
Argument trf is not a conformal transform (see property Revit::DB::Transform::IsConformal)
|
ArgumentNullException |
A non-optional argument was null
|
See Also