RebarContainerParameterManagerGetElementIdOverrideValue Method |
Get the ElementId value for an overriden parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetElementIdOverrideValue(
ElementId paramId
)
Public Function GetElementIdOverrideValue (
paramId As ElementId
) As ElementId
public:
ElementId^ GetElementIdOverrideValue(
ElementId^ paramId
)
member GetElementIdOverrideValue :
paramId : ElementId -> ElementId
Parameters
- paramId ElementId
-
The id of the parameter
Return Value
ElementId
The override value of the parameter.
ExceptionsException | Condition |
---|
ArgumentException |
paramId is not the id of a parameter in the current document,
or its value type is not ElementId.
-or-
paramId is not a Rebar Container parameter
-or-
paramId has no override
|
ArgumentNullException |
A non-optional argument was null
|
See Also