ComponentRepeaterDefaultFamilyType Property |
The default family type for the component repeater.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId DefaultFamilyType { get; set; }
Public Property DefaultFamilyType As ElementId
Get
Set
public:
property ElementId^ DefaultFamilyType {
ElementId^ get ();
void set (ElementId^ value);
}
member DefaultFamilyType : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Invalid type for the repeater. The type must be an adaptive family with no shape handles.
In addition, it must have same category and same number of placement points as the current type of the repeater.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
The default family type is the type of the instances in default slots. This includes slots that are added when the repeater grows.
When setting this property, all slots with instances of the default type will change their components to an instance of the new default type.
Empty slots will remain unchanged.
Slots with non-default family instances will remain unchanged.
See Also