StructuralSectionsServiceData Class

The data needed by section type server to perform type definition.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureStructuralSectionsServiceData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionsServiceData : IDisposable

The StructuralSectionsServiceData type exposes the following members.

Properties
 NameDescription
Public propertyDocument The current document.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the StructuralSectionsServiceData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCurrentElements Returns the list of Ids of the current elements.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also