StructuralSectionsServiceData Class

The data needed by section type server to perform type definition.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureStructuralSectionsServiceData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionsServiceData : IDisposable

The StructuralSectionsServiceData type exposes the following members.

Properties
 NameDescription
Public propertyDocument The current document.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the StructuralSectionsServiceData
Public methodGetCurrentElements Returns the list of Ids of the current elements.
Top
See Also